Supported jQuery versions

Home Forums Latest release 1.1.x Supported jQuery versions

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #8350
    jola
    Participant

    I have noticed problems running Smartmenus with the latest jQuery version (3.3.1). Does Smartmenus require an older version of jQuery? Which is the latest version of jQuery that is supported?

    Here is an example of a problem: If I run my own test-menu with the same jQuery version as is used on this site (1.7.2) then everything works okay. When I run with the latest jQuery version (3.3.1) and re-scale my browser window down to mobile size the drop-down menu disappears correctly and the hamburger icon is displayed, as it should. However, when I click the hamburger icon to open the mobile menu then the only thing that happens is that the hamburger icon changes to an “X”. If I then click the X the menu appears and the icon changes to an hamburger menu again. Thins then keeps being incorrect as I click – mobile menu appears when the hamburger menu is shown and is gone when the “X” is shown. If I scale out the browser window when the “X” is on and the menu is gone then once I reach the threshold width everything disappears and I get an empty page without any menu or icon.

    #8351
    jola
    Participant

    I’m responding to myself here. After having tested different jQuery version I have discovered that the versions that do not work with Smartmenus are the “slim” versions that exclude the ajax and effects modules. The latest jQuery version 3.3.1 seems to work well as long as I use the normal version and not the “slim” version. Can someone confirm that the “slim” versions are not supported by Smartmenus?

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Register

You will be emailed a link to set your password.

Login

Lost password?