SmartMenus v6.0 Separator is offset

Home Forums Older releases 0.9.x SmartMenus v6.0 Separator is offset

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2786
    MayhemMechanix
    Participant

    For some reason, the separator is appearing after the first letter of the next menu item. I’ve searched the forum under “separator” and only found one entry. I just need to know where to change the positioning of the vertical separator.

    #2787
    MayhemMechanix
    Participant

    To further clarify… There’s a huge space between the black arrow and the separator for the next item. Is there any way to reduce this space?

    #2790
    admin
    Keymaster

    In SmartMenus 6 there was the following property in “c_config.js”:

    0,		// ItemsSeparatorSpacing

    but I suppose tweaking this will not fix the issue and most probably some of your other page styles are conflicting with the SmartMenus styles and overriding them. So if possible, please post an URL to some kind of live demo where I could investigate the issue. Otherwise, it’s impossible to guess what exactly might be causing it.

    #2845
    MayhemMechanix
    Participant

    Regretfully, the server is internal only. It’s for our shop floor’s tracking system.

    Right now, I have ItemSeparatorSize at 8. This places the separator bar immediately to the left of the menu item. There’s still a huge space between the black triangle/down arrow and the ItemSeparator. This is what I am trying to reduce in order to fit the menu items closer together in the menu bar.

    #2846
    MayhemMechanix
    Participant

    Setting the item separator size to 0 takes it away, and everything collapses to the left. Is there any reason why there’s so much space to the left of the item separator?

    #2861
    admin
    Keymaster

    Items should be stacked together with the separators with no space in-between if ItemsSeparatorSpacing is set to 0. So, as I mentioned, most probably some of your other page styles are conflicting with the SmartMenus styles and overriding them. However, unfortunately, it’s impossible for me to guess what exactly might be causing the issue without looking at and being able to test your code.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Register

You will be emailed a link to set your password.

Login

Lost password?