FireFox issue with parent submenu link

Home Forums Older releases 0.9.x FireFox issue with parent submenu link

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #3106
    robotchips
    Participant

    Hi There,

    Here is the issue – It only exists in FF.

    When you click on the toplevel/parent menu item of our site (in mobile/device view), the menu item clicks to the page vs. actually opening the menu dropdown items. I don’t believe this is “as designed” in the UI. Is there something I goofed on or missed in the implementation perhaps?

    Here is our test site. Please ignore the extreme number of menu items. We use this for testing.

    Appreciate any help 🙂

    -Joseph

    #3116
    admin
    Keymaster

    Hm, just tested with the latest Firefox on Mac. For me, the first click shows the sub menu and the second click loads the link of the parent item. Isn’t this what you need?

    #3122
    robotchips
    Participant

    I failed to mention, it’s only the [ + ] area where the 2nd click was failing and loading the link in FF. We were actually able to fix by just updating to the latest version of your script (we were still running on the jquery.smartmenus beta) Does that sound accurate? 🙂

    Appreciate you looking into.

    #3128
    admin
    Keymaster

    Yes, v0.9.x had a different bahavior in collapsible mode – i.e. the “+” was just an indicator and not an actual toggle button. So now that you’ve upgraded, the +/- button is a toggle button acting independently from the rest of the menu item so I believe everything should be OK now.

    Cheers!

    #3185
    robotchips
    Participant

    Hello!

    so sorry to open this bug again! we have this issue resolved in all browsers, devices, etc except for the Samsung Galaxy Tab, we’ve noticed the 2nd click of the [+] opens the page vs clicking to close current parent menu group – Does that make sense?

    Would you have any insight or help in this matter?

    Thank you!

    #3193
    robotchips
    Participant

    Sorry, can anyone provide any help on this one?

    #3251
    admin
    Keymaster

    Sorry for this late reply, didn’t notice your post by now!

    So you have this issue in collapsible mode? I am not able to reproduce it on any Android device I have. What is the screen size of the tablet and what version of Android does it run?

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

Register

You will be emailed a link to set your password.

Login

Lost password?